$re = '/(?:@pattern\s+)?(?:@color\s+)?@product(?:\s+with @[A-Z,a-z]+)?/m';
$str = 'I am looking for a @color @product with @pattern and @pattern @color @product.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);