$re = '/(?<=#start)(.+)(?=#end)/is';
$str = '#start
hello powershell regex
what is the equivalent of flags gis
#end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);