$re = '/[a-zA-Z]+(?:[^a-zA-Z]+[a-zA-Z]+){3}[^a-zA-Z]*$/m';
$str = 'blah blah blah blah blah.
lkjhf lkjqsdf lkjhr ioqusr iortnb lkqjsdf mlkjj,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);