#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:new |\((?!new))([A-Z][\w]+))|([A-Z][\w]+)::"
Local $sString = "new User" & @CRLF & _
"new hej" & @CRLF & _
"(user()" & @CRLF & _
"new LOl fsdfdsf" & @CRLF & _
"User::"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")