import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:new |\\((?!new))([A-Z][\\w]+))|([A-Z][\\w]+)::";
final String string = "new User\n"
+ "new hej\n"
+ "(user()\n"
+ "new LOl fsdfdsf\n"
+ "User::";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}