$re = '/((?:new |\((?!new))([A-Z][\w]+))|([A-Z][\w]+)::/';
$str = 'new User
new hej
(user()
new LOl fsdfdsf
User::';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);