re = /((?:new |\((?!new))([A-Z][\w]+))|([A-Z][\w]+)::/
str = 'new User
new hej
(user()
new LOl fsdfdsf
User::'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end