#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.+ )"
Local $sString = "AAAAAAA ................................................. 28.02%" & @CRLF & _
"AAAAA-BBBBB, AB ........................................ 16.50%" & @CRLF & _
"AAAAAAA ................................................ 28.02%" & @CRLF & _
"AAAAA-BCCCC, AB ........................................ 16.50%" & @CRLF & _
"CCCCCCC ................................................ 28.02%" & @CRLF & _
"AAAAA-DDDDD, AB ........................................ 16.50%" & @CRLF & _
"FFFFFFF ................................................ 28.02%" & @CRLF & _
"AAAAA-BBBBB, AB ........................................ 16.50%"
Local $sSubst = "| "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)