#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?=(\d)\d\d([\s\-\x{2013}\x{2014}\/]))(?<![\d\-\x{2013}\x{2014}%])(?!000|666|9\d\d|\1{3}.\1{2}.\1{4}?|012.34.5678|123.45.6789|234.56.7890|098.76.5432|876.54.3210|078.05.1120|219.09.9999)\d{3}\2(?!00)\d{2}\2(?!0000)\d{4}(?![\d\-\x{2013}\x{2014}%])(?!\.(?:pdf|docx?|xlsx?|pptx?|zip|jpe?g|png|txt|log)\b)"
Local $sString = "################" & @CRLF & _
"## Must match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"123-45-4891" & @CRLF & _
"098-18-6564" & @CRLF & _
"123-45-4848" & @CRLF & _
"702-02-0202" & @CRLF & _
"001-14-0004" & @CRLF & _
"" & @CRLF & _
"009 95 8881" & @CRLF & _
"123-45-4891 is my ssn" & @CRLF & _
"my ssn is 123-45-4891" & @CRLF & _
"my ssn is 123-45-4891 ok?" & @CRLF & _
"my ssn is 123-45-4891." & @CRLF & _
"123454891 is my ssn" & @CRLF & _
"" & @CRLF & _
"123 45 4891 is my ssn" & @CRLF & _
"my ssn is 123 45 4891" & @CRLF & _
"my ssn is 123 45 4891 ok?" & @CRLF & _
"my ssn is 123 45 4891." & @CRLF & _
"my ssn is:123-45-4891." & @CRLF & _
"my ssn is:123 45 4891." & @CRLF & _
"my ssn is:123454891." & @CRLF & _
"ss#123-45-4891" & @CRLF & _
"ssn123-45-4891" & @CRLF & _
"" & @CRLF & _
"# Space separator:" & @CRLF & _
"123 45 4891" & @CRLF & _
"" & @CRLF & _
"# Emdash separator:" & @CRLF & _
"123–45–4891" & @CRLF & _
"" & @CRLF & _
"# Endash separator:" & @CRLF & _
"123—45—4891" & @CRLF & _
"" & @CRLF & _
"# Slash separator" & @CRLF & _
"123/45/4891" & @CRLF & _
"" & @CRLF & _
"################" & @CRLF & _
"## Must not match:" & @CRLF & _
"################" & @CRLF & _
"" & @CRLF & _
"# Unformatted SSN:" & @CRLF & _
"009958881" & @CRLF & _
"my ssn is 123454891" & @CRLF & _
"my ssn is 123454891 ok?" & @CRLF & _
"my ssn is 123454891." & @CRLF & _
"" & @CRLF & _
"# All-Zero sequence" & @CRLF & _
"231-84-0000" & @CRLF & _
"231-00-7289" & @CRLF & _
"000-87-7289" & @CRLF & _
"231 84 0000" & @CRLF & _
"231 00 7289" & @CRLF & _
"000 87 7289" & @CRLF & _
"" & @CRLF & _
"# Starting with 9" & @CRLF & _
"908-78-0485" & @CRLF & _
"908 78 0485" & @CRLF & _
"" & @CRLF & _
"# Starting with 666" & @CRLF & _
"666-78-0485" & @CRLF & _
"" & @CRLF & _
"# Same number sequences:" & @CRLF & _
"222-22-2222" & @CRLF & _
"555-55-5555" & @CRLF & _
"" & @CRLF & _
"# Ascending/Descending sequences:" & @CRLF & _
"123-45-6789" & @CRLF & _
"876-54-321" & @CRLF & _
"" & @CRLF & _
"# Known invalidated SSN:" & @CRLF & _
"219-09-9999" & @CRLF & _
"078-05-1120" & @CRLF & _
"" & @CRLF & _
"# File names with common extensions:" & @CRLF & _
"123-45-4891.pdf" & @CRLF & _
"123-45-4891.xlsx" & @CRLF & _
"Check the attachment: 123-45-4891.xls, then get back to me." & @CRLF & _
"Check the attachment: 123-45-4891.jpeg, then get back to me." & @CRLF & _
"" & @CRLF & _
"# Extra digits:" & @CRLF & _
"1123-45-4891" & @CRLF & _
"123-45-48911" & @CRLF & _
"" & @CRLF & _
"# Unsupported boundaries:" & @CRLF & _
"–123-45-4891" & @CRLF & _
"—123-45-4891" & @CRLF & _
"%123-45-4891" & @CRLF & _
"123-45-4891-" & @CRLF & _
"123-45-4891—" & @CRLF & _
"123-45-4891%" & @CRLF & _
"1-123-45-4891" & @CRLF & _
"123-45-4891-1" & @CRLF & _
"" & @CRLF & _
"# Telephone" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901" & @CRLF & _
"1-234-567-8901 " & @CRLF & _
"1 (234) 567-8901" & @CRLF & _
"12347658901" & @CRLF & _
"" & @CRLF & _
"# Credit card " & @CRLF & _
"5500 0000 0000 0004" & @CRLF & _
"3400 0000 0000 009" & @CRLF & _
"3000 0000 0000 04" & @CRLF & _
"5500-1244-2232-0004" & @CRLF & _
"3400-1244-0000-009" & @CRLF & _
"3000-1244-1234-04" & @CRLF & _
"" & @CRLF & _
"# Random Numbers" & @CRLF & _
"1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79" & @CRLF & _
"122-426-389" & @CRLF & _
"187-5-43212" & @CRLF & _
"187-0-43212" & @CRLF & _
"2423-45-6789" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")