$re = '/\bnew\s+Alert\((?:(?!\.showAndWait\(\);\s*$)[\s\S])*"\);/m';
$str = 'new Alert(AlertType.INFORMATION, "This alert should not be matched").showAndWait();
new Alert(AlertType.INFORMATION, "This alert should be matched");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);