import Foundation
let pattern = #"(?<!(?:<ul>)|(?:<\/ul>)|(?:<\/li>))([\n\r]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
te
<ul>
<li>iasd</li>
<li>asd</li>
</ul>
ja
123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)