# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[,.!?]//g;t' <<< "This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma."