using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[,.!?]";
string substitution = @"";
string input = @"This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}