$re = '/[,.!?]/';
$str = 'This is a test for replacing characters:
Dots..., question marks?, exclamation marks!
And of course, the comma.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;