package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/([^/]*)\/[^/]*\/$`)
var str = `https://www.facebook.com/pages/Something/976313416535/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}