$re = '/\/([^/]*)\/[^/]*\/$/m';
$str = 'https://www.facebook.com/pages/Something/976313416535/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);