re = /\/([^\/]*)\/[^\/]*\/$/m
str = 'https://www.facebook.com/pages/Something/976313416535/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end