re = /^[^\/.]+/m
str = 'job.batch/monitoring-cloud12390200
service/monitoring-opentt-collector'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end