#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(\+?011-?)?599(416|717|318)[0-9]{4}" & @CRLF & _
"|" & @CRLF & _
"08[58]-?[0-9]{7}(,[1-9][0-9]{1,8})?" & @CRLF & _
"|" & @CRLF & _
"(\+31|0|0031)[1-9][0-9]{2}-?[1-9][0-9]{5}(,[1-9][0-9]{1,8})?" & @CRLF & _
"|" & @CRLF & _
"(\+31|0|0031)[1-9][0-9]-?[1-9][0-9]{6}(,[1-9][0-9]{1,8})?" & @CRLF & _
"|" & @CRLF & _
"14-?0[1-9][0-9]{1,2}" & @CRLF & _
"|" & @CRLF & _
"(\+31|0|0031)6-?[1-9][0-9]{7}" & @CRLF & _
"|" & @CRLF & _
"\+(1\d{4,14}|2[078]\d{3,13}|3[0-469]\d{3,13}|4[013-9]\d{3,13}|5[1-9]\d{3,13}|6[0-6]\d{3,13}|7\d{4,14}|8[1-469]\d{3,13}|9[0-58]\d{3,13}|[2-9]\d{4,14})"
Local $sString = "03151364512"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")