# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?<time>(?:[\d]+\:[\d]+:[\d]+)\s+(?:AM|PM))(?:\s+\|\s+\w+\s+(?<edited>(?:[\d]+\:[\d]+:[\d]+)\s+(?:AM|PM)))?\]\s+(?<author>\w+)\:\s+(?<message>[\w\s,.]+)"
test_str = ("[9:14:51 AM] Jeff: If you could just do me a favoure and list all these concerns and in a mail and if you have any ideas that you might want to implement so that I can get everybodys notes.\n"
"[9:14:56 AM] Timmy: in terms of websites or domains or DNSs I have no clue about setup\n"
"[9:15:19 AM | Edited 9:15:25 AM] Jeff: That, I will get Sam and Frodo involved in\n"
"[9:16:01 AM] Jeff: I am stepping out quickly")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.