$re = '/^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$/m';
$str = 'a@b
max.mustermann@bahn.de
team-ümlaut@test.com
stußmail@ümlaut.tülüdü
_@test.de
@.de
.@.
ohneATgehtnix.de
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);