package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)^(?:https|http)\:\/\/github\.com\/([a-zA-Z0-9]+)\/([a-zA-Z0-9\.\-_]+)$`)
var str = `https://github.com/shoaiyb/sysacss`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}