package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)vector_name=(\w+)`)
var str = `options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}