use strict;
my $str = 'options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}';
my $regex = qr/vector_name=(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}