// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)vector_name=(\w+)").unwrap();
let string = "options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}