import Foundation
let pattern = #"vector_name=(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
options={}, params={vector_name=get_x, default_like_count=2, seeting_id=1200, system=0 back
literal options={}, params={setting_id=1200, seed_val=22, system=0, vector_name=get_Z foobar}
params={seed_rand=1200, seed_val=22, system=0, vector_name=corodinate2, tt=lly}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)