import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\s*(const|let|var)\\s*)(\\w+)(\\s*=\\s*)(require\\s*\\(\")(\\w+)(\"\\s*\\)\\s*;))";
final String string = "const path = require (\"path\") ;\n"
+ "let path = require(\"path\");\n"
+ "var path = require(\"path\");";
final String subst = "$4,$7";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}