$re = '/\bSpecialDay\b/m';
$str = 'hey! Hello World. SpecialDayForMe
hey! Hello World. SpecialDay ForMe
Hello world. SpecialDay
Hello world. SpecialDay. It certainly is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);