# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![^\sa-z])\d+(?![^\sa-z])"
test_str = ("15x20x30 -> 'values': [15,20,30]\n"
"15bits -> 'values': [15]\n"
"15 -> 'values': [15]\n"
"x15 -> 'values': [15]\n\n"
"but should not match:\n\n"
"456.48\n"
"888,12\n"
"6,4.8,4684.,6")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.