#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![Ll]ine\b).*\b(TIMEKEEPER|CLIENT|LAW FIRM)\b.*$"
Local $sString = "Line 1 : Missing required fields" & @CRLF & _
"line 2 : No Delimiter" & @CRLF & _
"PL is not approved TIMEKEEPER" & @CRLF & _
"CLIENT ABC is not authorized" & @CRLF & _
"LAW FIRM address is required" & @CRLF & _
"address is required" & @CRLF & _
"ABC is not authorized"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")