re = /\{
\s* ([a-zA-Z_][a-zA-Z0-9_-]*) \s*
(?:
: \s* ([^{}]*(?:\{(?-1)\}[^{}]*)*)
)?
\}/mx
str = '{hello}
{hello:xxx}
{hello:xxx{yyy}}
{hello:xxx{yyy:zzz}aaa}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end