using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Offset:[ ]+(10{0,2}(?:,0{3})?|10?(?:,0{3}){2})(?![,\d])";
string input = @"abdc Offset: 1 some more text
abdc Offset: 10 some more text
abdc Offset: 100 some more text
abdc Offset: 1,000 some more text
abdc Offset: 10,000 some more text
abdc Offset: 100,000 some more text
abdc Offset: 1,000,000 some more text
abdc Offset: 10,000,000 some more text
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}