import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Offset:[ ]+(10{0,2}(?:,0{3})?|10?(?:,0{3}){2})(?![,\\d])";
final String string = "abdc Offset: 1 some more text\n"
+ "abdc Offset: 10 some more text\n"
+ "abdc Offset: 100 some more text\n"
+ "abdc Offset: 1,000 some more text\n"
+ "abdc Offset: 10,000 some more text\n"
+ "abdc Offset: 100,000 some more text\n"
+ "abdc Offset: 1,000,000 some more text\n"
+ "abdc Offset: 10,000,000 some more text\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}