$re = '/(?=(\()\s*(?\'MeineZahl\'[\d]{1,3})\s*(?=\)))/m';
$str = 'UDTKCVSP ( 31 )
UDTKCVSP (31)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);