using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[13579](?=[13579])";
string substitution = @"$0-";
string input = @"999463";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}