import Foundation
let pattern = #"<TransactionID>(?<transID>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode>.*?)<\/ActionCode>.*?<Token>(?<token>.*?)<\/Token>.*?<Approval>(?<approv>.*?)<\/Approval>.*?<CVV2>(?<cvv>.*?)<\/CVV2>.*?<ResponseText>(?<respon>.*?)<\/ResponseText>.*?<VerificationResult>(?<verify>.*?)<\/VerificationResult>|<TransactionID>(?<transID2>.*?)<\/TransactionID>.*?<ActionCode>(?<actcode2>.*?)<\/ActionCode>.*?<ResponseText>(?<respon2>.*?)<\/ResponseText>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<ippayResponse><TransactionID>K20201022144133757</TransactionID><ActionCode>000</ActionCode><Token>4E3C5K3B7H0A1000</Token><Approval>TEST35</Approval><CVV2>N</CVV2><ResponseText>APPROVED</ResponseText><VerificationResult>0</VerificationResult></ippayResponse>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)