const regex = /\b[0-9]{10}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[0-9]{10}\\b', 'gm')
const str = `National Provider Identifier
Requirements: 10 consecutive digit number
Pattern:
\\b[0-9]{10}\\b
Test Cases:
Positive (should fire):
10 digits consecutively 1234507890
Embedded in text with spaces NPI: oops 1234507890 there is text here
Negative (should not fire):
Too many digits 12345078901
Not consecutive 1234567-890
Embedded in text no spaces oops1234507890there is text here
Phone number formats:
2028080012 (this one will fire, false positive)
202-808-0012
202.808.0012
202 808 0012 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}