const regex = /^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?"?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\\s?([0-5]?[0-9])?\\\'?\\s?([0-5]?[0-9](?:.{1}[0-9])?)?"?$', 'mg')
const str = `180° 1' 3"
// Stop at 360°
360° 1' 2"
-360° 1' 2"
259° 59' 59.9"
// Can't accept 2 digit precision decimal seconds.
259° 59' 59.99"
// Negative angle
-45° 1' 2"
// A little bit weird
00° 1' 2"
00° 00' 00.0"
// Whops! Something wrong here.
1° 2' 599"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}