use strict;
my $str = '180° 1\' 3"
// Stop at 360°
360° 1\' 2"
-360° 1\' 2"
259° 59\' 59.9"
// Can\'t accept 2 digit precision decimal seconds.
259° 59\' 59.99"
// Negative angle
-45° 1\' 2"
// A little bit weird
00° 1\' 2"
00° 00\' 00.0"
// Whops! Something wrong here.
1° 2\' 599"
';
my $regex = qr/^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?"?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}