import Foundation
let pattern = #"^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?"?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
180° 1' 3"
// Stop at 360°
360° 1' 2"
-360° 1' 2"
259° 59' 59.9"
// Can't accept 2 digit precision decimal seconds.
259° 59' 59.99"
// Negative angle
-45° 1' 2"
// A little bit weird
00° 1' 2"
00° 00' 00.0"
// Whops! Something wrong here.
1° 2' 599"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)