re = /^[\w ]+:[^\S\r\n]?\${[A-Z_]+}(?:\r?\n[\w ]+:[^\S\r\n]?\${[A-Z_]+})*$/m
str = 'Text description: ${VARIABLE_NAME}
Text description: ${VARIABLE_NAME}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end