using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bstyle(?:=([""'])[^""]*\1)?";
string input = @"style=""font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;""
style=""
style=""something""
style
style='font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}