$re = '/(["\'])(?:(?=(\\\\?))\2.)*?\1/m';
$str = 'Must match
--------
"a"
\'a a\'
\'a"a\'
"a\'\'a"
"a\'\\"\\"\'a"
"\\"\\"\\""
--------
Must not match
--------
"a
"\\"
"a\'
\'a"
--------
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);