package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\d|3[0-1])T([0-4]\d|5[0-9]):([0-4]\d|5[0-9]):([0-4]\d|5[0-9])(\.\d{3})?Z$`)
var str = `2019-01-01T00:00:00Z
1000-01-01T00:00:00.000Z
2019-12-31T59:59:59.999Z
2019-13-32T60:60:60Z
2019-00-00T00:00:00Z
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}