import re
regex = re.compile(r"^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Sandy Smith. Last message: Will do! 2/2/17.\n\n"
"Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17.\n\n\n"
"thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16.\n\n"
"BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM.\n\n"
"BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday.\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")