Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$
/
gmi
Test String
New
Sandy Smith. Last message: Will do! 2/2/17. Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17. thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16. BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM. BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday.