# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[a-z]\b\s*//gmi;t' <<< "A abc, B xyz, C mlk ooo"