const regex = /^((?!^\/api\/auth\/|\/(favicon|icon|apple-icon)\.(ico|jpg|jpeg|png|svg)$|^\/(assets|public)\/).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!^\\\/api\\\/auth\\\/|\\\/(favicon|icon|apple-icon)\\.(ico|jpg|jpeg|png|svg)$|^\\\/(assets|public)\\\/).)*$', 'gm')
const str = `## Next.js middleware config matcher regex
# ~ https://nextjs.org/docs/app/building-your-application/routing/middleware#matcher
# ~ https://nextjs.org/docs/app/api-reference/file-conventions/middleware#config-object-optional
# Public - skip middleware
/api/auth/*
/favicon.ico
/assets/*
/public/*
# Private - use middleware
/*
/api/*
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}