use strict;
my $str = 'yi12345678
i1234567
i12345u8
12345678
papave23 ciao il mio pin papaver1 è reeredji332ji con vaff8loe 1234567o 123t123t papavero 9o 123t123y
dssdsdsffvdffvdfv
389223897894237234894722348972348924
';
my $regex = qr/(\b(?![A-Za-z]{7,})(?![\d]{7,})(?=[a-zA-Z\d]{2})[A-Za-z\d]{8}\b)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}