using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"5002(?!H)";
string input = @"/?wkz=5002
/?wkz=5002HA-M
/?wkz=5002HB
/?wkz=5002HB-M
/?wkz=5002HF
/?wkz=5002HF-M";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}